Download BeadLogic

Java 1.8 or newer is required to run BeadLogic. For technical support, please contact Miltenyi Biotec

BeadLogic Manuals


Full Manual Full Manual


BeadLogic Installation Guide BeadLogic Installation Guide


License Activation & Managing ‘Your Account’ online License Activation & Managing ‘Your Account’ online


BeadLogic - Remote License Activation and Release BeadLogic - Remote License Activation and Release


BeadLogic Tutorials

Setup in FlowLogic Setup in FlowLogic
Analysis Workflow Analysis Workflow




  |   Licence Terms & Conditions  |   Inivai Privacy Policy  |